re = /(?<integer>(?:[0-9](?!\d*\.))+)|(?<float>[0-9]+[.][0-9]+)|(?<invalid>[^\s]+)/m
str = '2.2BLA3.1
12
12.2
1212.323
21
1
'
subst = 'x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result