const regex = /bab\K|b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('bab\\K|b', 'g')
const str = `bbabbbbb`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);