$re = '/<food>(?:(?!<food>).)*?<\/food>\s*<\/menu>/ms';
$str = '<menu>
<food>
<name>Burgers</name>
<price>$5</price>
</food>
<food>
<name>Fries</name>
<price>$3</price>
</food>
<food>
<name>Dessert</name>
<price>$4</price>
</food>
</menu>
<menu>
<food>
<name>Burgers</name>
<price>$5</price>
</food>
<food>
<name>Fries</name>
<price>$3</price>
</food>
<food>
<name>Dessert</name>
<price>$4</price>
</food>
</menu>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);