import re
regex = re.compile(r"(unpacking of archive failed|Cannot find package|exit 1|ERROR: |Error: |Error |ERROR|Failed |Failed: |Failed$|Failed\(\d+\):)", flags=re.MULTILINE)
test_str = "[682/932] perl-module-test2-plugin-exit 100% | 0.0 B/s | 8.5 KiB | 00m00s"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")