using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(5\d{3})(?=\s|$)";
string input = @"At this period by adding 52000 more particles we reched the value of 5810";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}