# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+ - (\w+(?: \w+)+) \(\d{4}-\d{4}\)/$1/gm;t' <<< "50 - David Herd (1961-1968)
49 - Teddy Sheringham (1997-2001)
48 - George Wall (1906-1915)
47 - Stan Pearson (1935-1954)
46 - Harry Gregg (1957-1966)
45 - Paddy Crerand (1963-1971)
44 - Jaap Stam (1998-2001)
43 - Paul Ince (1989-1995)
42 - Dwight Yorke (1998-2002)"