package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bc\+\+\B`)
var str = `c++ developer
using c++ language
c++word
c++.word
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}