import re
regex = re.compile(r"@\K[A-Z0-9]+(?:-[A-Z0-9]+)*", flags=re.MULTILINE | re.IGNORECASE)
test_str = "Hello @1a1a-1a1a and @2B2B2-B2 too"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")