$re = '/Employee ID:\s\w+/m';
$str = 'XXXXXXX
2018 Distribution (including true up for 2017)
Information about the Partnership
Taxpayer ID: XXXXXXX
Partnership Name: XXXXXXX
Partnership Address: 167827676178829
Information about the Member
Member Name: John Smith
Employee ID: 111trghADG611111
We can solve this using Employee ID:\\s[^\\n\\r]* or Employee ID:\\s\\d+
Member Address: 14552671';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);