$re = '/^(\d{3})(\d{3})(\d{2})(\d{2})$/m';
$str = '0221985324';
$subst = "$1 $2 $3 $4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;