re = /(?<!\S)(\d{4})([AB]?)([CD]?)(?!\S)/
str = 'Some text T7878/6767 1234AD and some more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end