package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^\s][^\s]+\s){2}(?P<field1>[^\s]+(?:\s\w+)?)\s\d+\s+<`)
var str = `<37> 1 2018-04-23T08:08:08Z E876876876 auth 0 <login> [kdnckn rrgrr]
<37> 1 2018-04-23T08:08:08Z E876876876 SECURE AUDIT 0 <secure audit error> [cdkncdckne dckmdkcmd]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}