$re = '/^\*?[^*]+\*?$/m';
$str = 'ALLOW:
*string*
*string
string*
string
DENY:
*str*ing*
*str*ing
str*ing*
str*ing
*string**
**
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);