const regex = new RegExp('\\s*((?:\\d+\\.\\s*\\d+|(?:No|M[rs]|[JD]r|S(?:r|gt))\\.|\\.(?!\\s+-?[A-Z0-9])|[^.!?])+(?:[.?!]|$))', 'gm')
const str = `I am from New York, N.Y. and I would like to say hello! How are you today? I am well. I owe you \$6. 00 because you bought me a No. 3 burger. -Sgt. Smith`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}