re = /^((?!\b((?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:(?<!\.)\b|\.)){4}).)*$/m
str = '10.123.34.12
asdADSas 3242 .
10.123.34.12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end