$re = '/^[0-9.]+\s\[[0-9-:\s]+\]\s\[[A-Z]+\s\/\]\s\:\s\[[A-Z]+\]\s-\s(.+)$/mi';
$str = '127.0.0.1 [2021-12-16 20:09:00] [GET /] : [INFO] - PHP Debug Log.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);