import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<reducer>\\w+)\\(\\)\\s+of\\s+query\\((?P<dashboardUID>\\w+)\\/(?P<panelID>\\d+)\\/(?P<metric>.+),\\s+(?P<from>\\w+),\\s+(?P<to>\\w+)\\)\\s+is\\s+(?P<evaluator>\\w+)\\((?P<params>-*\\d*[\\.,\\s]*\\d*\\w*)\\)\\s*(for\\s+\\((?P<for>\\w+)\\))*\\s*(every\\((?P<every>\\w+)\\))*\\s*$";
final String string = "avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is below(14)\n"
+ "avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is below(0.4)\n"
+ "avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is novalue()\n"
+ "avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is withinrange(4, 88)\n"
+ "avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is withinrange(4, 88) for (1m)\n"
+ "avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is withinrange(4, 88) for (1m) every(1m)\n"
+ "avg() of query(summary/152/tx-avg, 1m, now) is below(5000)\n"
+ "avg() of query(summary/152/tx-avg, 1m, now) is below(-5000)\n"
+ "avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is above(300M)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}