$re = '/<[fF]\d*>/m';
$str = 'filename.<f3>.exr.gz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);