const regex = /jjj[0-9]+(\.[0-9][0-9]?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('jjj[0-9]+(\\.[0-9][0-9]?)', 'g')
const str = `03-Feb-2021
Mr./Ms. JOHN THACHIL
MADHURA SURAKSHA APARTMENT
S6 2ND FLOOR
JP NAGAR 5TH PHASE
BANGALORE 560078
Dear Customer,
Subject: EasyEMI on your HDFC Bank Credit Card Number:jjj552260XXXXXX0961
We are pleased to grant you the EasyEMI payment facility as per the details stated below. The
transaction amount has been converted into EasyEMI as per your request
EasyEMI Loan no. 0000000000065214714
Unsecured Loan Type EasyEMI
Amount Rs.3399.00
Tenure 3 Months
EasyEMI Fixed Finance Charges on Reducing Balance 1.25% p.m.
EMI Amount Rs.1161.44(Excluding GST)*
Merchant Name
Processing Fee Rs.199.00
*GST at 18% will be charged on the following and are subjected to change as per Govt.Announcement:
1.EasyEMI Finance Charges Component on the EMI amount on a monthly basis
2.Processing fee, if any
3.Pre-closure charges, if any
Please refer to the enclosed amortization schedule for EMI details
For the first EMI, the interest will be calculated from the loan booking date till the payment due date. This
is effective only for loans booked from Feb 2019 onwards.In case you require any further assistance , pls
contact Phone Banking within 7 days of receiving this letter
EasyEMI transactions are not eligible for Reward Points.This EasyEMI can be pre-closed anytime during the
tenure. In case of pre-closure of the EasyEMI facility, there will be no Penalty levied currently. As the pre-closure
charge is subjected to change, we request you to get in touch with your nearest call centre for the applicable
charge, if any, if you decide to pre-close the EasyEMI. Partial pre-payment or partial closure is not permitted on
this loan
Additional Finance Charges if any on the principal outstanding from last statement date till date of loan pre-
closure need to be paid by customer.
Please also note that the above mentioned EMI amounts will be included to your monthly HDFC Bank Credit Card
statements and will be payable as part of the Minimum Amount Due.
If your HDFC Bank Card gets closed before all the installments have been charged, the loan outstanding will get
debited to your card account and you’re expected to pay the amount in full. In case of default in payment of credit
card dues or EMIs by the due dates, your card account is liable to be suspended and could further be terminated.
The terms and conditions contained in the Cardmember Agreement apply over and above the terms and
conditions for this loan. In case you do not agree to any of the details above, or require any further assistance,
please contact the nearest customer service call centre at the numbers provided below, within 7 days of receiving
this letter.
Enclosed Amortization schedule of Loan Number 0000000000065214714 for Loan Amount Rs.3399.00
(*GST extra @18% on Interest Component)
NojjjNo
EasyEMIjjjEasyEMI
StatementjjjPrincipaljjjEMIjjjBalancejjjStatementjjjPrincipaljjjEMIjjjBalance
FinancejjjFinance
DatejjjAmountjjjAmountjjjDatejjjAmountjjjAmount
ChargesjjjCharges
onjjjon
ReducingjjjReducing
BalancejjjBalance
21-02-2021jjj21-04-2021
1jjj1118.96jjj70.88jjj1189.84jjj2280.04jjj3jjj1147.10jjj14.33jjj1161.43jjj0.00
21-03-2021
2jjj1132.94jjj28.50jjj1161.44jjj1147.10
This is a computer generated letter and does not require a signature.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}