package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\(\d{3}\) |\d{3}-)\d{3}-\d{4}$`)
var str = `(123) 123-4567
123-123-1234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}