$re = '/(?<=-i-).*/';
$str = '24352435234543-i-jdshfgb sjfbhjsak';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);