$re = '/^(?!.*\bcarcinoma\b).*\b(renal|kidney)\b.*/m';
$str = 'Renal cell carcinoma
Clear cell carcinoma of kidney
Chronic renal impairment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);