import re
regex = re.compile(r"\[\D+\d\s*\D.*", flags=re.MULTILINE)
test_str = ("[F3- Salir]\n"
"[ F6 - Documento Material > ]\n"
"[ F7 - Entrega Distribucion > ]\n"
"[ F9 - Documento Inventario > ]\n"
"[ F8 - Validacion Documento > ]\n"
"[ F2 - Varios > ]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")