import re
regex = re.compile(r"^https:\/\/(www\.)?[-a-zA-Z0-9@:%._+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_+.~#?&//=]*)$", flags=re.MULTILINE)
test_str = ("https://www.google.com\n"
"https://google.com\n"
"https://test.example.com\n"
"https://dashboard-staging.com\n"
"https://dashboard-staging.com/bro/good\n"
"www.google.com\n"
"fgdsfdsf\n"
"ffdsf.com\n"
"fsdfs.comfsfds\n"
".cfom\n"
"http://dashboard-staging.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")