import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z][a-z]*(([A-Z]{1,3}[a-z]+)*[A-Z]{0,3}|([a-z]+[A-Z]{1,3})*|[A-Z]{1,3})$";
final String string = "snake_case\n"
+ "PascalCase\n"
+ "2PascalCase\n"
+ "streamIOIO\n"
+ "gREATERDtha\n"
+ "modeADFAFdsADFads\n"
+ "aBabcABCDabcABC\n"
+ "lThan30DaysCount\n"
+ "lessThan30DaysCount\n"
+ "lessThan30DaysCountA\n"
+ "greaterThan30LessThan60DaysCount\n"
+ "greaterThan60LessThan90DaysCount\n"
+ "greaterThan90DaysCount\n"
+ "aabc123\n"
+ "gREA1\n"
+ "cP3\n"
+ "a1\n"
+ "a123\n"
+ "a1G\n"
+ "hELLO\n"
+ "camel01C\n"
+ "camel01c01\n"
+ "camel01C01\n"
+ "camel01CC01\n"
+ "camel0a1c1\n"
+ "camel0a1C1\n"
+ "camel0ac1b1C1\n"
+ "mode2A\n"
+ "mode2A2\n"
+ "mode2A2A\n"
+ "pascal2Case\n"
+ "pascal2CaseA\n"
+ "contextHTMLParser\n"
+ "camelCa1\n"
+ "camelCa_1\n"
+ "supportsIpv6OnIos\n"
+ "affine3D\n"
+ "camelC1\n"
+ "modeADFdsADFads\n"
+ "streamIO\n"
+ "aBCabcABCabcA\n"
+ "aBCabcA\n"
+ "aabcABC\n"
+ "ab\n"
+ "abc\n"
+ "abcd\n"
+ "abcde\n"
+ "deviceSNS\n"
+ "pathASNs\n"
+ "dscpCP\n"
+ "awsVPC\n"
+ "serialNo\n"
+ "deviceID\n"
+ "camelCasecamelCasecamelCasecamelCasecamelCasecamelCase\n"
+ "gREAt\n"
+ "gREAtREAt\n"
+ "aABC\n"
+ "modeADFsADFads\n"
+ "aG\n"
+ "a\n"
+ "modeADFads\n"
+ "camelCase\n"
+ "pascalCase\n"
+ "pascalCaseA\n"
+ "modeA\n"
+ "createAMode\n"
+ "createBMode\n"
+ "madeEasy\n"
+ "wonderFul\n"
+ "andMe\n"
+ "htmlParser\n"
+ "h\n"
+ "aaA\n"
+ "camelC\n"
+ "camelCA\n"
+ "ibsReleaseTestVerificationRegressionSuite\n"
+ "ibsReleaseTestVerificationRegressioNSuite\n"
+ "ibsReleaseTestVerificationRegressioN\n"
+ "xmlHttpRequest\n"
+ "newCustomerId\n"
+ "innerStopwatch\n"
+ "youTubeImporter\n"
+ "youtubeImporter";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}