#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s\S{6}\s(?<codec>(\w|-)+)\s{3}"
Local $sString = "Encoders:" & @CRLF & _
" V..... = Video" & @CRLF & _
" A..... = Audio" & @CRLF & _
" S..... = Subtitle" & @CRLF & _
" .F.... = Frame-level multithreading" & @CRLF & _
" ..S... = Slice-level multithreading" & @CRLF & _
" ...X.. = Codec is experimental" & @CRLF & _
" ....B. = Supports draw_horiz_band" & @CRLF & _
" .....D = Supports direct rendering method 1" & @CRLF & _
" ------" & @CRLF & _
" V..... a64multi Multicolor charset for Commodore 64 (codec a64_multi)" & @CRLF & _
" V..... a64multi5 Multicolor charset for Commodore 64, extended with 5th color (colram) (codec a64_multi5)" & @CRLF & _
" V..... alias_pix Alias/Wavefront PIX image" & @CRLF & _
" V..... amv AMV Video" & @CRLF & _
" V..... apng APNG (Animated Portable Network Graphics) image" & @CRLF & _
" V..... asv1 ASUS V1" & @CRLF & _
" V..... asv2 ASUS V2" & @CRLF & _
" V..X.. libaom-av1 libaom AV1 (codec av1)" & @CRLF & _
" V..... avrp Avid 1:1 10-bit RGB Packer" & @CRLF & _
" V..X.. avui Avid Meridien Uncompressed" & @CRLF & _
" V..... ayuv Uncompressed packed MS 4:4:4:4" & @CRLF & _
" V..... bmp BMP (Windows and OS/2 bitmap)" & @CRLF & _
" V..... cinepak Cinepak" & @CRLF & _
" V..... cljr Cirrus Logic AccuPak" & @CRLF & _
" V.S... vc2 SMPTE VC-2 (codec dirac)" & @CRLF & _
" VFS... dnxhd VC3/DNxHD" & @CRLF & _
" V..... dpx DPX (Digital Picture Exchange) image" & @CRLF & _
" VFS... dvvideo DV (Digital Video)" & @CRLF & _
" V.S... ffv1 FFmpeg video codec #1" & @CRLF & _
" VF.... ffvhuff Huffyuv FFmpeg variant" & @CRLF & _
" V..... fits Flexible Image Transport System" & @CRLF & _
" V..... flashsv Flash Screen Video" & @CRLF & _
" V..... flashsv2 Flash Screen Video Version 2" & @CRLF & _
" V..... flv FLV / Sorenson Spark / Sorenson H.263 (Flash Video) (codec flv1)" & @CRLF & _
" V..... gif GIF (Graphics Interchange Format)" & @CRLF & _
" V..... h261 H.261" & @CRLF & _
" V..... h263 H.263 / H.263-1996" & @CRLF & _
" V..... h263_v4l2m2m V4L2 mem2mem H.263 encoder wrapper (codec h263)" & @CRLF & _
" V.S... h263p H.263+ / H.263-1998 / H.263 version 2" & @CRLF & _
" V..... libx264 libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 (codec h264)" & @CRLF & _
" V..... libx264rgb libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 RGB (codec h264)" & @CRLF & _
" V..... h264_nvenc NVIDIA NVENC H.264 encoder (codec h264)" & @CRLF & _
" V..... h264_omx OpenMAX IL H.264 video encoder (codec h264)" & @CRLF & _
" V..... h264_v4l2m2m V4L2 mem2mem H.264 encoder wrapper (codec h264)" & @CRLF & _
" V..... h264_vaapi H.264/AVC (VAAPI) (codec h264)" & @CRLF & _
" V..... nvenc NVIDIA NVENC H.264 encoder (codec h264)" & @CRLF & _
" V..... nvenc_h264 NVIDIA NVENC H.264 encoder (codec h264)" & @CRLF & _
" V..... libx265 libx265 H.265 / HEVC (codec hevc)" & @CRLF & _
" V..... nvenc_hevc NVIDIA NVENC hevc encoder (codec hevc)" & @CRLF & _
" V..... hevc_nvenc NVIDIA NVENC hevc encoder (codec hevc)" & @CRLF & _
" V..... hevc_v4l2m2m V4L2 mem2mem HEVC encoder wrapper (codec hevc)" & @CRLF & _
" V..... hevc_vaapi H.265/HEVC (VAAPI) (codec hevc)" & @CRLF & _
" VF.... huffyuv Huffyuv / HuffYUV" & @CRLF & _
" V..... jpeg2000 JPEG 2000" & @CRLF & _
" VF.... libopenjpeg OpenJPEG JPEG 2000 (codec jpeg2000)" & @CRLF & _
" VF.... jpegls JPEG-LS" & @CRLF & _
" VF.... ljpeg Lossless JPEG" & @CRLF & _
" VF.... magicyuv MagicYUV video" & @CRLF & _
" VFS... mjpeg MJPEG (Motion JPEG)" & @CRLF & _
" V..... mjpeg_vaapi MJPEG (VAAPI) (codec mjpeg)" & @CRLF & _
" V.S... mpeg1video MPEG-1 video" & @CRLF & _
" V.S... mpeg2video MPEG-2 video" & @CRLF & _
" V..... mpeg2_vaapi MPEG-2 (VAAPI) (codec mpeg2video)" & @CRLF & _
" V.S... mpeg4 MPEG-4 part 2" & @CRLF & _
" V..... libxvid libxvidcore MPEG-4 part 2 (codec mpeg4)" & @CRLF & _
" V..... mpeg4_v4l2m2m V4L2 mem2mem MPEG4 encoder wrapper (codec mpeg4)" & @CRLF & _
" V..... msmpeg4v2 MPEG-4 part 2 Microsoft variant version 2" & @CRLF & _
" V..... msmpeg4 MPEG-4 part 2 Microsoft variant version 3 (codec msmpeg4v3)" & @CRLF & _
" V..... msvideo1 Microsoft Video-1" & @CRLF & _
" V..... pam PAM (Portable AnyMap) image" & @CRLF & _
" V..... pbm PBM (Portable BitMap) image" & @CRLF & _
" V..... pcx PC Paintbrush PCX image" & @CRLF & _
" V..... pgm PGM (Portable GrayMap) image" & @CRLF & _
" V..... pgmyuv PGMYUV (Portable GrayMap YUV) image" & @CRLF & _
" VF.... png PNG (Portable Network Graphics) image" & @CRLF & _
" V..... ppm PPM (Portable PixelMap) image" & @CRLF & _
" VF.... prores Apple ProRes" & @CRLF & _
" VF.... prores_aw Apple ProRes (codec prores)" & @CRLF & _
" VFS... prores_ks Apple ProRes (iCodec Pro) (codec prores)" & @CRLF & _
" V..... qtrle QuickTime Animation (RLE) video" & @CRLF & _
" V..... r10k AJA Kona 10-bit RGB Codec" & @CRLF & _
" V..... r210 Uncompressed RGB 10-bit" & @CRLF & _
" V..... rawvideo raw video" & @CRLF & _
" V..... roqvideo id RoQ video (codec roq)" & @CRLF & _
" V..... rv10 RealVideo 1.0" & @CRLF & _
" V..... rv20 RealVideo 2.0" & @CRLF & _
" V..... sgi SGI image" & @CRLF & _
" V..... snow Snow" & @CRLF & _
" V..... sunrast Sun Rasterfile image" & @CRLF & _
" V..... svq1 Sorenson Vector Quantizer 1 / Sorenson Video 1 / SVQ1" & @CRLF & _
" V..... targa Truevision Targa image" & @CRLF & _
" V..... libtheora libtheora Theora (codec theora)" & @CRLF & _
" VF.... tiff TIFF image" & @CRLF & _
" VF.... utvideo Ut Video" & @CRLF & _
" V..... v210 Uncompressed 4:2:2 10-bit" & @CRLF & _
" V..... v308 Uncompressed packed 4:4:4" & @CRLF & _
" V..... v408 Uncompressed packed QT 4:4:4:4" & @CRLF & _
" V..... v410 Uncompressed 4:4:4 10-bit" & @CRLF & _
" V..... libvpx libvpx VP8 (codec vp8)" & @CRLF & _
" V..... vp8_v4l2m2m V4L2 mem2mem VP8 encoder wrapper (codec vp8)" & @CRLF & _
" V..... vp8_vaapi VP8 (VAAPI) (codec vp8)" & @CRLF & _
" V..... libvpx-vp9 libvpx VP9 (codec vp9)" & @CRLF & _
" V..... vp9_vaapi VP9 (VAAPI) (codec vp9)" & @CRLF & _
" V..... libwebp_anim libwebp WebP image (codec webp)" & @CRLF & _
" V..... libwebp libwebp WebP image (codec webp)" & @CRLF & _
" V..... wmv1 Windows Media Video 7" & @CRLF & _
" V..... wmv2 Windows Media Video 8" & @CRLF & _
" V..... wrapped_avframe AVFrame to AVPacket passthrough" & @CRLF & _
" V..... xbm XBM (X BitMap) image" & @CRLF & _
" V..... xface X-face image" & @CRLF & _
" V..... xwd XWD (X Window Dump) image" & @CRLF & _
" V..... y41p Uncompressed YUV 4:1:1 12-bit" & @CRLF & _
" V..... yuv4 Uncompressed packed 4:2:0" & @CRLF & _
" VF.... zlib LCL (LossLess Codec Library) ZLIB" & @CRLF & _
" V..... zmbv Zip Motion Blocks Video" & @CRLF & _
" A..... aac AAC (Advanced Audio Coding)" & @CRLF & _
" A..... ac3 ATSC A/52A (AC-3)" & @CRLF & _
" A..... ac3_fixed ATSC A/52A (AC-3) (codec ac3)" & @CRLF & _
" A..... adpcm_adx SEGA CRI ADX ADPCM" & @CRLF & _
" A..... g722 G.722 ADPCM (codec adpcm_g722)" & @CRLF & _
" A..... g726 G.726 ADPCM (codec adpcm_g726)" & @CRLF & _
" A..... g726le G.726 little endian ADPCM ("right-justified") (codec adpcm_g726le)" & @CRLF & _
" A..... adpcm_ima_qt ADPCM IMA QuickTime" & @CRLF & _
" A..... adpcm_ima_wav ADPCM IMA WAV" & @CRLF & _
" A..... adpcm_ms ADPCM Microsoft" & @CRLF & _
" A..... adpcm_swf ADPCM Shockwave Flash" & @CRLF & _
" A..... adpcm_yamaha ADPCM Yamaha" & @CRLF & _
" A..... alac ALAC (Apple Lossless Audio Codec)" & @CRLF & _
" A..... libopencore_amrnb OpenCORE AMR-NB (Adaptive Multi-Rate Narrow-Band) (codec amr_nb)" & @CRLF & _
" A..... aptx aptX (Audio Processing Technology for Bluetooth)" & @CRLF & _
" A..... aptx_hd aptX HD (Audio Processing Technology for Bluetooth)" & @CRLF & _
" A..... comfortnoise RFC 3389 comfort noise generator" & @CRLF & _
" A..X.. dca DCA (DTS Coherent Acoustics) (codec dts)" & @CRLF & _
" A..... eac3 ATSC A/52 E-AC-3" & @CRLF & _
" A..... flac FLAC (Free Lossless Audio Codec)" & @CRLF & _
" A..... g723_1 G.723.1" & @CRLF & _
" A..... libgsm libgsm GSM (codec gsm)" & @CRLF & _
" A..... libgsm_ms libgsm GSM Microsoft variant (codec gsm_ms)" & @CRLF & _
" A..X.. mlp MLP (Meridian Lossless Packing)" & @CRLF & _
" A..... mp2 MP2 (MPEG audio layer 2)" & @CRLF & _
" A..... mp2fixed MP2 fixed point (MPEG audio layer 2) (codec mp2)" & @CRLF & _
" A..... libmp3lame libmp3lame MP3 (MPEG audio layer 3) (codec mp3)" & @CRLF & _
" A..... nellymoser Nellymoser Asao" & @CRLF & _
" A..X.. opus Opus" & @CRLF & _
" A..... libopus libopus Opus (codec opus)" & @CRLF & _
" A..... pcm_alaw PCM A-law / G.711 A-law" & @CRLF & _
" A..... pcm_f32be PCM 32-bit floating point big-endian" & @CRLF & _
" A..... pcm_f32le PCM 32-bit floating point little-endian" & @CRLF & _
" A..... pcm_f64be PCM 64-bit floating point big-endian" & @CRLF & _
" A..... pcm_f64le PCM 64-bit floating point little-endian" & @CRLF & _
" A..... pcm_mulaw PCM mu-law / G.711 mu-law" & @CRLF & _
" A..... pcm_s16be PCM signed 16-bit big-endian" & @CRLF & _
" A..... pcm_s16be_planar PCM signed 16-bit big-endian planar" & @CRLF & _
" A..... pcm_s16le PCM signed 16-bit little-endian" & @CRLF & _
" A..... pcm_s16le_planar PCM signed 16-bit little-endian planar" & @CRLF & _
" A..... pcm_s24be PCM signed 24-bit big-endian" & @CRLF & _
" A..... pcm_s24daud PCM D-Cinema audio signed 24-bit" & @CRLF & _
" A..... pcm_s24le PCM signed 24-bit little-endian" & @CRLF & _
" A..... pcm_s24le_planar PCM signed 24-bit little-endian planar" & @CRLF & _
" A..... pcm_s32be PCM signed 32-bit big-endian" & @CRLF & _
" A..... pcm_s32le PCM signed 32-bit little-endian" & @CRLF & _
" A..... pcm_s32le_planar PCM signed 32-bit little-endian planar" & @CRLF & _
" A..... pcm_s64be PCM signed 64-bit big-endian" & @CRLF & _
" A..... pcm_s64le PCM signed 64-bit little-endian" & @CRLF & _
" A..... pcm_s8 PCM signed 8-bit" & @CRLF & _
" A..... pcm_s8_planar PCM signed 8-bit planar" & @CRLF & _
" A..... pcm_u16be PCM unsigned 16-bit big-endian" & @CRLF & _
" A..... pcm_u16le PCM unsigned 16-bit little-endian" & @CRLF & _
" A..... pcm_u24be PCM unsigned 24-bit big-endian" & @CRLF & _
" A..... pcm_u24le PCM unsigned 24-bit little-endian" & @CRLF & _
" A..... pcm_u32be PCM unsigned 32-bit big-endian" & @CRLF & _
" A..... pcm_u32le PCM unsigned 32-bit little-endian" & @CRLF & _
" A..... pcm_u8 PCM unsigned 8-bit" & @CRLF & _
" A..... pcm_vidc PCM Archimedes VIDC" & @CRLF & _
" A..... real_144 RealAudio 1.0 (14.4K) (codec ra_144)" & @CRLF & _
" A..... roq_dpcm id RoQ DPCM" & @CRLF & _
" A..X.. s302m SMPTE 302M" & @CRLF & _
" A..... sbc SBC (low-complexity subband codec)" & @CRLF & _
" A..X.. sonic Sonic" & @CRLF & _
" A..X.. sonicls Sonic lossless" & @CRLF & _
" A..... libspeex libspeex Speex (codec speex)" & @CRLF & _
" A..X.. truehd TrueHD" & @CRLF & _
" A..... tta TTA (True Audio)" & @CRLF & _
" A..X.. vorbis Vorbis" & @CRLF & _
" A..... libvorbis libvorbis (codec vorbis)" & @CRLF & _
" A..... wavpack WavPack" & @CRLF & _
" A..... wmav1 Windows Media Audio 1" & @CRLF & _
" A..... wmav2 Windows Media Audio 2" & @CRLF & _
" S..... ssa ASS (Advanced SubStation Alpha) subtitle (codec ass)" & @CRLF & _
" S..... ass ASS (Advanced SubStation Alpha) subtitle" & @CRLF & _
" S..... dvbsub DVB subtitles (codec dvb_subtitle)" & @CRLF & _
" S..... dvdsub DVD subtitles (codec dvd_subtitle)" & @CRLF & _
" S..... mov_text 3GPP Timed Text subtitle" & @CRLF & _
" S..... srt SubRip subtitle (codec subrip)" & @CRLF & _
" S..... subrip SubRip subtitle" & @CRLF & _
" S..... text Raw text subtitle" & @CRLF & _
" S..... webvtt WebVTT subtitle" & @CRLF & _
" S..... xsub DivX subtitles (XSUB)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")