import Foundation
let pattern = #"(?i)([^"\.]+)(?=.exe)\.\w{2,3}.([^"]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Send('BLA.CMD "Testasdf.exe" folder\file.txt asdf123')
Send('{enter}')
ShellExecute(@ScriptDir & "\folder\file.txt")
ShellExecute(@HomeDrive & "\Program Files\PROGRAMDIR\Program Dir\my program.exe", @ScriptDir & "\Testblabla.exe")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)