package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+?\d{1,4}[\s-]?)?(\(?\d{3}\)?[\s-]?)?\d{3}[\s-]?\d{4}$`)
var str = `07708654564
076543 4545 454
+441132382345
0800 456 6788
+93641126157`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}