$re = '~^Юр\.\h(.+?)\h+(\d+)\s*$~iu';
$str = 'юр. йцуsdf sdf sdf sdf sdf sdf sdf sdf4 345 3w wer 123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);