import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d)\\1{2}-(\\d)\\1{1}-(\\d)\\1{3}$";
final String string = "888888888\n"
+ "123456789\n"
+ "888-88-8888\n"
+ "123-45-6789\n"
+ "111-22-3333\n"
+ "333-33-3333";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}