$re = '/(\S+)\(([^)]+)\)/';
$str = 'text(text1) password(password1) in table(table_name) with some random text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);