$re = '/(?:thank you|thanks|thks|tnx|thx|^ta$)/';
$str = 'ta';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);