$re = '/_([YRGB]\d)(?!\d)/';
$str = 'blahblahblah_R1.blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);