package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/(.*\.)?linkedin\.com`)
var str = `https://linkedin.com
https://subdomain.linkedin.comcom
https://not-a-subdomain-linkedin.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}