// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(((mr|prof|dr|mrs|ms)\.\s\w+,?)|\w\.\w\.)").unwrap();
let string = "In in aliquet turpis. Donec pretium sodales metus mollis consequat! Sed non bibendum neque? Suspendisse hendrerit vel erat non cursus. Aenean eget lectus nulla. Mauris quam nulla, hendrerit ac congue gravida, interdum sit amet erat. I am the one that sees the dawn. See you at 5 P.M. tomorrow.
Ut vulputate leo sit amet turpis bibendum malesuada. Mr. Brown, Prof. Plumb and Ms. Scarlet all had thier reasons. Aliquam erat volutpat. Sed at feugiat dolor, quis bibendum magna. Donec sed neque eu ipsum eleifend accumsan. \"What that just isn't true .... no\" Quisque eu volutpat tellus, in hendrerit libero. Phasellus ac fermentum turpis. Nulla ullamcorper, justo placerat pulvinar scelerisque, justo elit gravida metus, nec tristique nisl purus eu leo.
In the year of our lord 2018 the people on earth where content in their unhappiness, oblivious of the inevitability of damnantion.
Asteroid ABV30004-442-23212-NONE
A sentense that ends oddly Mr.
Suspendisse semper posuere faucibus. Etiam ligula augue, pharetra ut massa ac, sodales faucibus augue. Duis dignissim felis et urna commodo, eget laoreet libero consectetur. Nam felis velit, efficitur et tortor in, molestie egestas erat. Nullam id metus nec ex mollis molestie quis in justo. Cras nec quam sem. Ut luctus in nibh sed molestie. Praesent ut \"dapibus ex suspendisse\" potenti. Curabitur consequat turpis at aliquam molestie.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}