re = /(Loi|Décret)\s+n°\s*(\d\d(?:\d\d)?\-\d{1,4})\s+du\s+([1-9][0-9]?)\s+(janvier|février|mars|avril|mai|juin|juillet|août|septembre|octobre|novembre|décembre)\s+(\d\d\d\d)\s+(.*)/i
str = 'LOI n° 2014-896 du 15 août 2014 relative à l\'individualisation des peines et renforçant l\'efficacité des sanctions pénales (1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end