package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w{32}_v2`)
var str = `1q2e5g6s4t5s2u1i5dy1s9614i2s5u9o_v2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}