using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>[^<]*)(abc)";
string input = @"<b>abc</b>
<abc>abc</abc>
abc
<abc id=""abc"">abc</abc>abcdefg ab c
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}