$re = '/"(\w+)\s*{([^{(]+)/m';
$str = '{"querys":"query{secondstring(input:{
{"query":"query{helloworld {sdsd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);