# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?*\[size=\d+].*?\[/size](.*))
(?=.{24,40}\1$)
.{0,39}t.*?(?=\1$)
"""
test_str = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed condimentum velit a felis commodo, ac efficitur nunc [size=27]Hello World[/size] dictum. Fusce auctor, [size=30]This is a test[/size] sit amet hendrerit commodo, [size=59]The quick brown fox jumps over the lazy dog[/size] enim augue consectetur nulla, vel blandit magna est vel sapien. Nam [size=42]Lorem ipsum dolor sit amet[/size] mattis ligula eu [size=41]Happiness is a warm puppy[/size] condimentum rhoncus. [size=21]Short[/size] Interdum et malesuada fames ac ante ipsum primis in faucibus. Donec interdum, [size=50]Supercalifragilisticexpialidocious[/size] ut posuere sapien venenatis vel."
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.