$re = '~(?*.{24,40}(.*))
(?=\[size=\d+].*?\[/size]\1$)
.{0,39}t.*?(?=\1$)~mx';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed condimentum velit a felis commodo, ac efficitur nunc [size=27]Hello World[/size] dictum. Fusce auctor, [size=30]This is a test[/size] sit amet hendrerit commodo, [size=59]The quick brown fox jumps over the lazy dog[/size] enim augue consectetur nulla, vel blandit magna est vel sapien. Nam [size=42]Lorem ipsum dolor sit amet[/size] mattis ligula eu [size=41]Happiness is a warm puppy[/size] condimentum rhoncus. [size=21]Short[/size] Interdum et malesuada fames ac ante ipsum primis in faucibus. Donec interdum, [size=50]Supercalifragilisticexpialidocious[/size] ut posuere sapien venenatis vel.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);