$re = '/Departure Date\/Time:(.{2,500}?\s)/m';
$str = 'Document/Message Date/Time:2006-11-15T18:07 Booking Date/Time: 2006-11-15T19:00
Arrival Date/Time:2006-11-15T21:00 Departure Date/Time: 2006-11-15T21:30
Free Text
Goods Description: 1 PALLETS RECEIVED DAMAGED 1234561 PALLETS RECEIVED DAMAGED 123456
Non-acceptance Information:1 PALLETS RECEIVED DAMAGED 1234561 PALLETS RECEIVED DAMAGED 123456
Details of Transport
Haulier Number:ABCD5678901234567
Haulier’s Name:CARRIERS NAME456789 Wkjhutuytyut
Name and Address Message
Tesco Receiving Centre Number: AP3456789 Wduiyiu
Depot Number:CLP456789 WzkjdhusWE
Name & Address Description:DEPOT NAME Wdkwadyuw786X
Location Identification
Place/Port of Loading:AA3456789012345678901234xPlace of Transhipment:CC3456789012345678901234x
Place/Port of Discharge: BB3456789012345678901234x Bording Crossing Place:DD3456789012345678901234x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);