const regex = /^(?<longtime>[^ ]+\s[^ ]+)\s\[(?<thread>[^\]]+)\]\s\[(?<loglevel>[A-Z]+)(?>[^\(]+)\((?<process>[^\)]+)\)\s+(?<message>.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<longtime>[^ ]+\\s[^ ]+)\\s\\[(?<thread>[^\\]]+)\\]\\s\\[(?<loglevel>[A-Z]+)(?>[^\\(]+)\\((?<process>[^\\)]+)\\)\\s+(?<message>.+)$', 'gm')
const str = `2019-06-05 09:35:43,001 [http-bio-8080-exec-4278] [ERROR] (o.a.r.v.i.MavenMetadataInterceptor:175) - IO exception retrieving maven metadata content from repo 'codehaus': Failed to parse metadata: end tag name </head> must be the same as start tag <meta> from line 25 (position: TEXT seen ... maximum-scale=1.0; user-scalable=0;" name="viewport">\\n </head>... @26:12) .
2019-06-04 15:36:16,981 [http-bio-8080-exec-4248] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-release-local:org/sonarsource/scanner/maven/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:16,981 [http-bio-8080-exec-4254] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-release-local:com/spotify/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:16,981 [http-bio-8080-exec-4236] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-snapshot-local:com/spotify/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:16,982 [http-bio-8080-exec-4256] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-snapshot-local:org/sonarsource/scanner/maven/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:17,024 [http-bio-8080-exec-4237] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-release-local:org/codehaus/mojo/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:17,024 [http-bio-8080-exec-4238] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-snapshot-local:org/apache/maven/plugins/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:17,025 [http-bio-8080-exec-4216] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-release-local:org/apache/maven/plugins/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:17,026 [http-bio-8080-exec-4257] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-snapshot-local:org/codehaus/mojo/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:17,071 [http-bio-8080-exec-4213] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-snapshot-local:org/sonarsource/scanner/maven/sonar-maven-plugin/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:17,072 [http-bio-8080-exec-4251] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-release-local:org/sonarsource/scanner/maven/sonar-maven-plugin/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:19,116 [http-bio-8080-exec-4242] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-snapshot-local:org/apache/maven/plugins/maven-compiler-plugin/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:19,116 [http-bio-8080-exec-4248] [WARN ] (o.a.r.ArtifactoryResponseBase:105) - Sending HTTP error code 403: Download request for repo:path 'ext-release-local:org/apache/maven/plugins/maven-compiler-plugin/maven-metadata.xml' is forbidden for user 'gispa-service-r00'.
2019-06-04 15:36:40,714 [art-exec-3128064] [INFO ] (o.a.s.a.ArchiveIndexerImpl:147) - Indexing archive: libs-snapshot-local:ru/russianpost/gispa/aps/appeals-boot/1.3.11-SNAPSHOT/appeals-boot-1.3.11-20190604.123558-2.jar
2019-06-04 15:36:41,094 [art-exec-3128064] [INFO ] (o.a.s.a.ArchiveIndexerImpl:147) - Indexing archive: libs-snapshot-local:ru/russianpost/gispa/aps/appeals-boot/1.3.11-SNAPSHOT/appeals-boot-1.3.11-20190604.123558-2-sources.jar
2019-06-04 15:36:41,112 [art-exec-3128064] [INFO ] (o.a.s.a.ArchiveIndexerImpl:147) - Indexing archive: libs-snapshot-local:ru/russianpost/gispa/aps/appeals-boot/1.3.11-SNAPSHOT/appeals-boot-1.3.11-20190604.123558-2-javadoc.jar
2019-06-04 15:36:41,140 [art-exec-3128064] [INFO ] (o.a.s.a.ArchiveIndexerImpl:147) - Indexing archive: libs-snapshot-local:ru/russianpost/gispa/aps/appeals-boot/1.3.11-SNAPSHOT/appeals-boot-1.3.11-20190604.123558-2-docker-info.jar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}