import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!`)`([^`\\r\\n]+)`(?!`)|(?<!`)```([^`\\r\\n]+)```(?!`)";
final String string = "`ab`\n"
+ "ab `cd` ef\n"
+ "`ab``\n"
+ "```efg```\n"
+ "ab```efg``` hi\n"
+ "```cd``\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}