$re = '/(?:<@!?(\d+)>)/';
$str = '<@399969178745962506> hello to <@!104729417217032192>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);