$re = '/(?=#\B)(.*)/m';
$str = '# www.admitme.app
# Carlo Baxter
# resumes in 15 minutes';
$subst = "$1 #";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;