$re = '/^(([a-zA-Z_\-0-9]+)(:[a-zA-Z_\-0-9]+)?@)?[a-zA-Z\-0-9.]+(:[0-9]{1,5})?(\/[a-zA-Z_\-]+)?$/m';
$str = 'us_e-0r:p_as0s@this.h0-ost.org:45555/my_gr-oups';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);