$re = '/(<a.*href="http:\/\/vk.com">.*<\/a>)/i';
$str = 'http://vk.com
<a href="http://vk.com">asd</a>
<a target="_blank" href="http://vk.com">asd</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);