import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-5]?[0-9])$";
final String string = "<--! select 0 or 00..59 sequences -->\n"
+ "0\n"
+ "1\n"
+ "9\n"
+ "00\n"
+ "09\n"
+ "10\n"
+ "33\n"
+ "45\n"
+ "55\n"
+ "59\n"
+ "99\n"
+ "000\n"
+ "001\n"
+ "002\n"
+ "004\n"
+ "010\n"
+ "011\n"
+ "021\n"
+ "100\n"
+ "101\n"
+ "110\n"
+ "115\n"
+ "120\n"
+ "125\n"
+ "127\n"
+ "135\n"
+ "139\n"
+ "141\n"
+ "201\n"
+ "222\n"
+ "230\n"
+ "245\n"
+ "247\n"
+ "250\n"
+ "254 sgnlfsf\n"
+ "2340\n"
+ "345\n"
+ "255\n"
+ "853\n"
+ "999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}