$re = '/\b(in|for|a)\b/m';
$str = 'hello include in the formula for attachment a dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);